Ubuntu na terra do pão di queijo

14/02/2008

Bastardo GPRS do inférno!!!

Filed under: Diversos,Software Livre,Ubuntu — Leonardo Amaral @ 23:28

Hoje brincando de fazer a GC85 (Troquei de placa) funcionar, esbarrei no mesmo problema dos 115200 bps de velocidade. Caçando por ai, achei um link bem sem vergonha (http://sergioflima.pro.br/blogs/index.php/sergio-blog/2007/07/19/tim_web_no_ubuntu_acer_travelmate) com um comentário mais infame ainda dizendo que um italiano tinha conseguido fazer estas porcarias se conectarem a 115200… Paguei pra ver e configurei o wvdial I G U A L Z I N H O o que ele fez (Até a ordem dos fatores). E não é que o filho de chocadeira do inferno funcionou?

Para quem quiser ver a saída:

leleobhz@astra:~$ cat /etc/wvdial.conf ; sudo wvdial
[Dialer Defaults]
Modem = /dev/ttyS2
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E0 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1, "IP", "claro.com.br","",0,0
Dial Command = ATDT
Phone = *99***1#
Username = claro
Password = claro
New PPPD = yes

WvDial<*1>: WvDial: Internet dialer version 1.56
WvDial<*1>: Initializing modem.
WvDial<*1>: Sending: ATZ
WvDial Modem<*1>: OK
WvDial<*1>: Sending: ATQ0 V1 E0 S0=0 &C1 &D2 +FCLASS=0
WvDial Modem<*1>: ATQ0 V1 E0 S0=0 &C1 &D2 +FCLASS=0
WvDial Modem<*1>: OK
WvDial<*1>: Sending: AT+CGDCONT=1, "IP", "claro.com.br","",0,0
WvDial Modem<*1>: OK
WvDial<*1>: Modem initialized.
WvDial<*1>: Sending: ATDT*99***1#
WvDial<*1>: Waiting for carrier.
WvDial Modem<*1>: CONNECT
WvDial Modem<*1>: ~[7f]}#@!}!^} }<}!}$}%\}"}&} } } } }#}$@#}%}&} a+r}'}"}(}"})r~
WvDial<*1>: Carrier detected.  Waiting for prompt.
WvDial Modem<*1>: ~[7f]}#@!}!^} }<}!}$}%\}"}&} } } } }#}$@#}%}&} a+r}'}"}(}"})r~
WvDial<*1>: PPP negotiation detected.
WvDial<Notice>: Starting pppd at Fri Feb 15 00:25:01 2008
WvDial<Notice>: Pid of pppd: 25417
WvDial<*1>: Using interface ppp0
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: local  IP address 10.124.52.147
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: remote IP address 10.124.52.0
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: primary   DNS address 200.255.121.39
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: secondary DNS address 200.169.117.14
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
Caught signal 2:  Attempting to exit gracefully...
WvDial<*1>: Terminating on signal 15
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: Connect time 0.3 minutes.
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: pppd: [10]�[06][08]8�[06][08]З[06][08]
WvDial<*1>: Disconnecting at Fri Feb 15 00:25:22 2008

# Another window / Noutro console:
leleobhz@astra:~$ ifconfig ppp0
ppp0       Encapsulamento do Link: Protocolo Ponto-a-Ponto
          inet end.: 10.124.52.147  P-a-P:10.124.52.0  Masc:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Métrica:1
          pacotes RX:3 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:4 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:3
          RX bytes:66 (66.0 b) TX bytes:87 (87.0 b)

leleobhz@astra:~$

Enfim terminado o mistério das plaquinhas da Sony.

P.s: Alguém pode testar com a GC86 e com a GC89?

P.s2: Li bem no final do texto do italiano que EDGE deveria ser 230400. EU TIVE SUCESSO nesta velocidade também.

Anúncios

9 Comentários »

  1. Eu serve pra testar com a GC89, mane?! :D

    Comentário por lombra — 14/02/2008 @ 23:31 | Responder

  2. Serve beshona! :p

    Comentário por Leonardo Amaral — 14/02/2008 @ 23:39 | Responder

  3. […] do serial_cs, na GC89 é IMPOSSIVEL conectar com mais de 57600 bps Há solução para isso! Veja aqui) e a Terminação, que deve ser feita por hardware. O resto é o trivial (Autenticação PAP/CHAP, […]

    Pingback por GPRS no Linux com SE GC89 « Ubuntu na terra do pão di queijo — 15/02/2008 @ 6:01 | Responder

  4. Tentei com uma GC89 no Ubuntu 7.10 e nao funciona a mais de 57600 nem a pau, usando exatamente estes comandos, e tambem tentei com outras configuracoes que encontrei por ai e nao funcionou de jeito nenhum. Mas meu chip eh Oi. =/

    Bem, amanha eu tento mais. ;)

    Comentário por Mauro Faccenda — 05/03/2008 @ 20:33 | Responder

  5. Faz tempo que estou tentando fazer funcionar minha placa GC89 no linux e ainda não foi desta vez.
    Não funciona!
    Eu até consigo conectar com 57600 mas não dá para navegar.
    Veja quantos pacotes perdidos no ping:

    PING google.com (64.233.167.99) 56(84) bytes of data.
    64 bytes from py-in-f99.google.com (64.233.167.99): icmp_seq=1 ttl=238 time=896 ms
    64 bytes from py-in-f99.google.com (64.233.167.99): icmp_seq=5 ttl=238 time=820 ms
    64 bytes from py-in-f99.google.com (64.233.167.99): icmp_seq=6 ttl=238 time=1359 ms
    64 bytes from py-in-f99.google.com (64.233.167.99): icmp_seq=9 ttl=238 time=688 ms
    64 bytes from py-in-f99.google.com (64.233.167.99): icmp_seq=10 ttl=238 time=742 ms
    64 bytes from py-in-f99.google.com (64.233.167.99): icmp_seq=12 ttl=238 time=680 ms
    64 bytes from py-in-f99.google.com (64.233.167.99): icmp_seq=13 ttl=238 time=399 ms

    — google.com ping statistics —
    13 packets transmitted, 7 received, 46% packet loss, time 33874ms
    rtt min/avg/max/mdev = 399.933/798.171/1359.975/270.892 ms, pipe 2

    Desanimador, mas ainda não desisti.

    Comentário por João Henrique — 18/04/2008 @ 19:25 | Responder

  6. Eu tenho a placa GC86. Configurei igual vc, mas qd peço pra rodar o wvdial, aparece uma msg dizendo que deu “Falha de segmentação”. Como resolvo isso, vc tem idéia?

    Comentário por Patrícia Souza — 30/09/2008 @ 12:11 | Responder

  7. Falha de segmentação significa que você tem algum problema com a sua instalação. Recomendo que você a principio tente:

    sudo aptitude clean
    sudo aptitude update
    sudo aptitude reinstall wvdial pppd

    Comentário por Leonardo Amaral — 30/09/2008 @ 21:38 | Responder

  8. Continua dando o mesmo erro…

    Comentário por Patrícia Souza — 02/10/2008 @ 14:16 | Responder

  9. […] ensinei coisas bacanas, ofendi e repudiei os evangélicos, bati cabeça no prego, desenvolvi muitas coisas boas e interessantes para e com o mundo SL, reconheci pessoas brilhantes (E que, ainda hoje […]

    Pingback por Papai noel… — 08/12/2008 @ 20:02 | Responder


RSS feed for comments on this post. TrackBack URI

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Crie um website ou blog gratuito no WordPress.com.

%d blogueiros gostam disto: